Java and Maven

From Clickframes

Installing Java

Java 1.6 is required for using Clickframes. Check the version of Java installed on your computer:

java -version

If you don't have Java installed, you can get Java 1.6 here:

http://www.java.com/en/download

Installing Maven

Maven is a make-like tool for Java. Clickframes uses Maven to build projects. Maven must be installed on your machine in order to use clickframes. If you don't have Maven installed, you can download it here:

http://maven.apache.org/download.html

After installing maven (which is usually unzipping maven in a directory and adding the bin directory to you path), you should be able to run the following command:

$ mvn -version
Maven version: 2.0.9
Java version: 1.6.0_10
OS name: "linux" version: "2.6.23.15-137.fc8" arch: "i386" Family: "unix"